Warning: Internet Explorer is no longer supported by SimpliSafe and will produce unexpected behavior. Please use a more modern browser like Edge, Chrome, or Firefox for the full SimpliSafe experience.
×

Need help finding something?

Take this short quiz to find the right security system for you.

get recommendations
No thanks

logging in to account

Don't know where to post this so starting here. I can't log int my account from main page. When I click on "log in" it opens a blank page and nothing happens. I can log in on the forums page. When logged in from forum link I still can't "view account". Help please.

I'm experiencing the same

I'm experiencing the same issue. "Log in" takes me to a blank page. I've checked the status of my account this way before with no problems.

Hi all, It may also be

Hi all,

It may also be beneficial to try logging into your account through an Incognito (Chrome) or a Private (Safari and Firefox) window to make sure that there aren't any extensions that are preventing the page from loading. A quick google search should be able to direct you on how to open up a private window to give that a try.

SimpliSafe Social Team
SimpliSafe Home Security

Thanks for nothing SimpliSafe

Thanks for nothing SimpliSafe Social Team!

In Firefox private window did not help.

Anything else to try?

Is it COINCIDENCE that my PHONE APP did the same thing? I had to REINSTALL it to make it work again......

Shall I reinstall WIndows 10?

For three days in a row I

For three days in a row I have gotten the message when I try to open my phone app; 'we are experiencing server problems. A few minutes later I am able to log in.
Server problems for a security company? Really?

I can log in into this forum,

I can log in into this forum, but I can't login in to my account. Is it normal?

I'm still unable to log in

I'm still unable to log in from my computer to my dashboard. I can get in through my phone but have limited settings then..

Hey, folks at SimpliSafe: Get

Hey, folks at SimpliSafe:
Get this: I can't log in into https://webapp.simplisafe.com/#/dashboard using Chrome or Brave. But it works if I use MS Edge.

What gives?

How do I log into my account

How do I log into my account

Hi @gstankus7, Once you go to

Hi @gstankus7,

Once you go to SimpliSafe.com you can easily log in by following these steps:

  1. Hover your cursor over the circular icon with the silhouette in it.
  2. Select Login from the drop-down menu.
  3. Enter your email address and password and then select Continue.
  4. If you haven't logged into your account through that browser recently, you may be prompted to verify your email address. If that happens, head over to your email, open up the email from us and follow the instructions.

That's it! At this point, you should be logged in to your SimpliSafe.com account. Alternatively, you can go to http://SimpliSafe.com/Login and then start at step 3 above.

SimpliSafe Social Team
SimpliSafe Home Security

I can’t log in either.

I can’t log in either. Followed the instructions above and still can’t login.

Hi dkkissell, Would you be

Hi dkkissell,

Would you be able to provide some details as to where the process is going wrong? We'll do our best to help you out here on the forums, but for an issue like this, it may be best to call in to our Support Team for more direct help. They can be reached at 1-800-297-1605 from 8 AM to Midnight ET, 7 days a week.

SimpliSafe Social Team
SimpliSafe Home Security

I just had the same problem

I just had the same problem blank page for login. Hard to imagine that people have been having the same problem
for over five months here and the people at simplisafe haven't fixed it
Makes you wonder if we really have any service at all,

Tried every which way to

Tried every which way to login. I get to the login and the email verification - when i hit continue the next page says: Connecting to SimpliSafe and goes no further. When i do get logged in i can go any where EXCEPT my account page?! Whats up with that? i have been able to log in without failure up until a couple of days ago. Haven't changed anything on my end.

On a merry-go-round! Login -

On a merry-go-round! Login - verification - email - login; round and round. The verification page refreshes every 2 seconds. Someone help us please!!! I am using iMac Safari and this has been going on for months. I can't believe a security company is having this issue. I have tried all above suggestions; nothing works. Maybe it's time to move on.

@klhon Not sure all of the

@klhon Not sure all of the steps you tried, but by chance are you using a VPN? If so, shut it off and try again. Do you use a cookie add on in your browser? If so, shut that off or configure it to allow cookies at the Simplisafe website. Still no go? Try a different browser. Finally, if all else fails call and walk through the issue with first level, and if that fails, specifically ask for a Simplisafe 2nd level agent in the Boston group.
Finally, I can, my phone, tablet and PC's all access my account fine. I emailed my merry little group of 30+ other owners and five got back to me almost immediately, no issues so chances are the issue is not on SS's side. Try and think of what may be different within your environment.

Hope some of this helps. Good luck and post your outcome here is you get a chance. Happy Holidays

They sold too many Christmas

They sold too many Christmas and Hannukah presents and can not cope with the hits.

If you are still not able to

If you are still not able to login, check top right corner of the Browser (Chrome). Most likely there is blocked message form security setting. You may need to click on it and unblock the site.

I am unable to operate upon

I am unable to operate upon my system from my phone through apple app. what is the problem with the system?

Nothing works!!! I need to

Nothing works!!! I need to get into my account to set-up a new credit card for future payments...NOW!

Hi all, It looks as though

Hi all,

It looks as though there may be a few different issues that people are currently having when logging into their accounts through SimpliSafe.com. The most common issues people seem to be having are getting stuck in some sort of verification loop as well as a blank screen after having logged in. Here's some information on these issues:

Verification Loop
This is generally caused by an issue with your cookie settings. In order to identify a unique device, SimpliSafe.com generates a unique ID for each browser that logs into your account. This ID is used to skip the verification process on a device that has previously been logged into your account and will only be generated if a unique ID doesn't already exist in your cookies. For customers who seem to be stuck in some sort of verification loop, most likely something is preventing this ID from being saved in your cookies, therefore a new one is being generated that requires the email address to be verified. This is most likely caused by cookies being disabled in your browser settings or an extension that manages your cookies.

Blank Screen
This is generally caused by a VPN or an adblocker that is preventing the website from loading properly after logging in. In most cases, logging out of the VPN or disabling the adblocker should resolve this issue. An easy way to verify if it is an adblocker that is causing the issue is to try to log in to SimpliSafe.com using an Incognito window (Chrome) or a Private window (Safari and Firefox) as extensions generally don't load in those although some adblockers may have a setting allowing them to do so.

If you continue to have issues logging into your SimpliSafe accounts after going through the above information, we recommend giving our Support Team a call. They can be reached at 1-800-548-9508 from 8 AM to Midnight ET, 7 days a week.

SimpliSafe Social Team
SimpliSafe Home Security

Simplisafe is absolutely the

Simplisafe is absolutely the worse alarm company i have used. Our alarm went off on Christmas day, Thank god the neighbor called me cause simpli safe took over an hour to call

I am having trouble logging

I am having trouble logging in to to my account from a web browser. I get a Verification Pending notice, so I click the link on the email on the Verify Device box where it then states, "Verification Successful". Next it states I may close the window, so I do, then the Log in window pops up and I enter the correct info. After that, I hit enter where a partial circle rotates and "Connecting to SimpliSafe" pops up for a while, then back to the Log in window. I've tried this several times to no avail.

I did the same on my Android phone and no problem.

II AM HAVE THE SAME PROBLEM

II AM HAVE THE SAME PROBLEM CAN NOT LOG IN TO MY ACCOUNT

@meat, suggest you contact

@meat, suggest you contact support. I can get into my account but SS did have server problems Friday night for several hours that brought the site down. (Monitoring was not effected). Support can troubleshoot with you.

Also, suggest once you do get in, change your forum user name from your email for privacy reasons. Please post your outcome here if you get a chance.